Baseball Card and Scoreboard 502 Bad Gateway
Incident Report for Performance Matters
Resolved
The issue preventing users from using the Baseball Card, Scoreboard, or Student Filters has been resolved. The site is fully operational.
Posted May 16, 2019 - 08:12 EDT
Identified
Users are currently receiving an error when trying to use the Baseball Card, Scoreboard, or Student Filter features. We have identified the issue and are working to quickly resolve it.

All other pages, features, and testing solutions are available and operational.
Posted May 16, 2019 - 08:03 EDT
This incident affected: Student Platform.