HelpDesk phone lines are down
Incident Report for Performance Matters
Resolved
The help desk phones were restored on Friday afternoon. Our apologies on any delay in contacting support.
Posted Jun 17, 2019 - 10:01 EDT
Investigating
We have been notified that users are not able to reach support by phone due to an issue with our vendor. Our IT department is currently working with the vendor to restore service.
Posted Jun 14, 2019 - 11:34 EDT
This incident affected: Student Platform and Educator Platform.