Performance degradation / Partial Outage
Incident Report for PowerSchool Products
Resolved
The systems have returned to normal operations. Our team will continue to monitor through the day.
Posted Mar 18, 2024 - 07:47 PDT
Monitoring
The partial outage has been resolved however users may still be experiencing some degradation. We will continue to monitor.
Posted Mar 18, 2024 - 07:18 PDT
Investigating
Atrieve is currently experiencing degradation that may affect users ability to login.
Posted Mar 18, 2024 - 07:09 PDT
This incident affected: Atrieve (HOST04).