SchoolMessenger Communicate Sites Unable To Be Accessed
Incident Report for PowerSchool Products
Resolved
At this time all performance has returned to normal and this issue is resolved. We appreciate your patience while we worked through this issue!
Posted Apr 05, 2024 - 11:48 PDT
Monitoring
A fix has been implemented for this issue and performance is returning to normal. Our teams will continue monitoring and post updates here as they become available.
Posted Apr 05, 2024 - 10:29 PDT
Identified
The issue has been identified, our teams are working to put a fix in place for this now. Updates will be posted here as they become available.
Posted Apr 05, 2024 - 10:23 PDT
Investigating
We are currently investigating an issue where some SchoolMessenger Communicate sites are inaccessible, giving an error "Invalid customer URL. Please check the web address and try again." Our teams have been engaged and are working diligently to resolve this. Updates will be posted here as they become available.
Posted Apr 05, 2024 - 10:06 PDT
This incident affected: SchoolMessenger (SchoolMessenger Communicate).