SchoolMessenger Communicate Sites Unable To Be Accessed
Incident Report for PowerSchool Products
Resolved
We have successfully resolved this issue at this time. We strive to provide the best possible experience for our customers and would like to thank you again for your patience as we worked to resolve this.
Posted Apr 14, 2024 - 12:53 PDT
Monitoring
A fix has been implemented for this issue and at this time all system performance has returned to normal. Our teams will continue monitoring to ensure functionality is maintained.
Posted Apr 14, 2024 - 12:27 PDT
Identified
We have identified the issue causing some SchoolMessenger Communicate sites to be inaccessible and are working to remediate this issue now. Updates will be posted here as they become available.
Posted Apr 14, 2024 - 10:45 PDT
Investigating
We are currently investigating an issue where some SchoolMessenger Communicate sites are inaccessible, giving an error "Invalid customer URL. Please check the web address and try again." Our teams have been engaged and are working diligently to resolve this. Updates will be posted here as they become available.
Posted Apr 14, 2024 - 10:10 PDT
This incident affected: SchoolMessenger (SchoolMessenger Communicate).