MyReports
Incident Report for Performance Matters
Resolved
The issue with MyReports has now been resolved.
Posted Oct 25, 2019 - 09:59 EDT
Investigating
We have identified an issue with MyReports. When generating any report, an error is thrown. Our Engineering team is working diligently to resolve the issue at this time. Subsequent updates to follow.
Posted Oct 25, 2019 - 09:53 EDT
This incident affected: Student Platform.