Monitoring - The systems have returned to normal operations. Our team will continue to monitor through the day.
Mar 11, 2024 - 10:17 PDT
Update - We are taking steps to mitigate the current incident. at 10:40AM Mountain, we will be doing a restart that will cause a disruption to Atrieve for all users. We appreciate your patience as we work to resolve the incident.
Mar 11, 2024 - 09:30 PDT
Investigating - We continue to investigate intermittent disruptions impacting Atrieve causing site accessibility issues and performance issues. We have determined that end-users continue to be impacted and our team is working to address the incident as quickly as possible.
Mar 11, 2024 - 08:29 PDT

About This Site

Find the status of our Unified Talent Products here: http://talentedstatus.powerschool.com/

Applicant Tracking Operational
Atrieve Operational
HOST02 Operational
HOST03 Operational
HOST04 Operational
HOST05 Operational
HOST06 Operational
HOST07 Operational
HOST08 Operational
HOST11 Operational
HOST12 Operational
HOST13 Operational
ADS03 Operational
ADS04 Operational
ADS05 Operational
ADS06 Operational
ADS07 Operational
ADS08 Operational
HOST31 Operational
HOST32 Operational
HOST33 Operational
HOST34 Operational
HOST35 Operational
BusinessPlus Operational
Cognos Reporting Operational
Connected Intelligence K-12 Operational
Connected Intelligence P20W Operational
eFinancePlus Operational
Document Cloud (US & Canada) Operational
Document Delivery US Operational
Document Signature US Operational
Document Management US Operational
Document Delivery Canada Operational
Document Signature Canada Operational
Document Management Canada Operational
Document Library Operational
Enrollment Operational
Enrollment Express/ECollect Operational
L4U Operational
My PowerSchool Operational
PowerSchool Messaging Operational
Naviance Operational
Perform Enterprise & Professional Learning Operational
Performance Matters Operational
PerformancePlus Operational
PowerPack Operational
Student Alert Management Operational
Early Warning System (EWS) Operational
Locker Management Operational
Flex Mailer Operational
Web Reports Operational
Utility Dashboard Operational
Enhanced PowerLunch Operational
Service Manager Operational
PowerSchool eSchoolPlus SIS Operational
PowerSchool Community Operational
PowerSchool SIS Operational
PowerSchool Trillium SIS Operational
Schoology Operational
Schoology Canada Operational
Schoology Operational
SchoolMessenger Operational
90 days ago
100.0 % uptime
Today
SchoolMessenger CustomApp Operational
SchoolMessenger Communicate Operational
SchoolMessenger PermissionClick Operational
SchoolMessenger Presence Operational
SchoolMessenger K-12 Social Operational
90 days ago
100.0 % uptime
Today
SmartFind Express Operational
Unified Classroom Behavior Support Operational
Unified Classroom Special Programs Operational
Unified Insights Operational
Unified Classroom Curriculum & Instruction ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
PowerSchool will be deploying version 24.3.0.0 of Professional Learning & Perform Enterprise to your server. During this time, system availability will be limited.
Posted on Mar 21, 2024 - 17:39 PDT
BusinessPlus Maintenance Apr 5, 2024 23:00 - Apr 6, 2024 23:00 PDT
The PowerSchool team is conducting a Full VM restart to complete OS patching on your BusinessPlus Production server. Customers may experience downtime during the maintenance window. To prepare for the upcoming OS Patching Server Reboots, the patches will be deployed in advance during the week leading up to the scheduled reboot. In rare instances, this may impact one or more servers if a patch is applied without necessitating a reboot.
Posted on Mar 27, 2024 - 09:41 PDT
PowerSchool SIS 24.3.2.0 Compliance Upgrade Apr 6, 2024 15:00 - Apr 7, 2024 06:00 PDT
We are updating PowerSchool SIS Compliance to version 24.3.2.0. Customers with auto-update enabled content will receive this update during the maintenance window. During this time, system availability will be limited.

Note: Excluding NC, AL, Stride and Middle East

Posted on Mar 25, 2024 - 17:56 PDT
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024
Completed - The scheduled maintenance has been completed.
Mar 23, 21:45 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 23, 20:45 PDT
Scheduled - PowerSchool is performing system maintenance on Enrollment, Special Programs, and PowerSchool SIS, including a firewall restart. The application will be unavailable for the majority of the window.
Mar 21, 17:36 PDT
Completed - The scheduled maintenance has been completed.
Mar 23, 03:30 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 22, 21:00 PDT
Scheduled - PowerSchool will be deploying version 24.3.0.0 of Performance Matters Advanced Reporting and Performance Matters Assesment to your server. During this time, system availability will be limited.
Mar 18, 11:56 PDT
Mar 22, 2024
Completed - The scheduled maintenance has been completed.
Mar 22, 22:00 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 22, 18:00 PDT
Scheduled - PowerSchool will be deploying version 24.3.0.0. of Enrollment to your server. The application is expected to remain online during the maintenance window.
Mar 13, 05:29 PDT
Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024
Resolved - We are no longer experiencing any widespread degraded performance with PowerSchool eSchoolPlus SIS, and all systems are working as expected.
Our team are continuing to monitoring the system performance.
If you are still experiencing degraded performance, please reach out to PowerSchool Support.

Mar 19, 08:51 PDT
Monitoring - A fix has been implemented and we are monitoring the results.
Mar 4, 13:35 PST
Investigating - We are currently investigating this issue.
Mar 4, 07:39 PST
Resolved - We are no longer experiencing any widespread degraded performance with PowerSchool SIS, and all systems are working as expected.
Our team are continuing to monitoring the system performance.
If you are still experiencing degraded performance, please reach out to PowerSchool Support.

Mar 19, 08:46 PDT
Update - We are no longer experiencing any widespread degraded performance with PowerSchool SIS, and all systems are working as expected.
Our team are continuing to monitoring the system performance, and we will keep you posted on the resolution and more details as they become available.
If you are still experiencing degraded performance, please reach out to PowerSchool Support.

Mar 5, 06:37 PST
Monitoring - We are aware of degraded performance with PowerSchool SIS. We are monitoring the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Mar 4, 07:23 PST
Mar 18, 2024
Resolved - The systems have returned to normal operations. Our team will continue to monitor through the day.
Mar 18, 07:47 PDT
Monitoring - The partial outage has been resolved however users may still be experiencing some degradation. We will continue to monitor.
Mar 18, 07:18 PDT
Investigating - Atrieve is currently experiencing degradation that may affect users ability to login.
Mar 18, 07:09 PDT
Completed - The scheduled maintenance has been completed.
Mar 18, 04:30 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 17, 18:00 PDT
Scheduled - PowerSchool will be deploying version 24.3.0.0 of Enrollment Express and Ecollect Forms to your server. The application will remain online during the maintenance window.
Mar 15, 14:10 PDT
Completed - The scheduled maintenance has been completed.
Mar 18, 01:00 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 17, 19:30 PDT
Scheduled - The PowerSchool team is conducting a Full VM restart to complete OS patching on your server. The application will be available for the majority of the window. However, customers will experience intermittent connectivity.
Mar 7, 09:02 PST
Mar 17, 2024
Mar 16, 2024
Completed - The scheduled maintenance has been completed.
Mar 16, 23:00 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 15, 23:00 PDT
Scheduled - The PowerSchool team is conducting a Full VM restart to complete OS patching on your BusinessPlus Non-production server. Customers may experience downtime during the maintenance window. To prepare for the upcoming OS Patching Server Reboots, the patches will be deployed in advance during the week leading up to the scheduled reboot. In rare instances, this may impact one or more servers if a patch is applied without necessitating a reboot.
Mar 7, 09:13 PST
Completed - The scheduled maintenance has been completed.
Mar 16, 10:30 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 16, 06:30 PDT
Scheduled - PowerSchool is performing system maintenance on Atrieve. The application will be unavailable for the majority of the window.

Note: This is a Scheduled Maintenance for all Atrieve customers except Trillium Lakelands and Northeastern.

Mar 12, 10:48 PDT
Completed - The scheduled maintenance has been completed.
Mar 16, 09:01 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 15, 21:01 PDT
Scheduled - PowerSchool will be deploying version 20.11.68.1 and 22.4.30.1 of eFinancePlus to your server. The application will be unavailable for the majority of the window.
Mar 15, 14:12 PDT
Completed - The scheduled maintenance has been completed.
Mar 16, 09:00 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 15, 21:00 PDT
Scheduled - We are updating PowerSchool eSchoolPlus SIS compliance to version 24.2.1.0. Customers with auto-update enabled will receive this update. The application will be unavailable for the majority of the window.
Mar 7, 13:35 PST
Completed - The scheduled maintenance has been completed.
Mar 16, 02:30 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 15, 18:30 PDT
Scheduled - PowerSchool will be deploying version 23.11.4.0 of Special Programs to your server. During this time, system availability will be limited.
Mar 7, 09:10 PST
Mar 15, 2024
Mar 14, 2024
Resolved - This incident has been resolved.
Mar 14, 12:07 PDT
Investigating - We are aware of a degraded performance with Document Delivery. We are working to assess the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Mar 14, 10:54 PDT