SchoolMessenger Communicate Performance Issues
Incident Report for PowerSchool Products
Resolved
At this time all performance has returned to normal and this issue is resolved. We appreciate your patience while we worked through this issue!
Posted Apr 05, 2024 - 11:49 PDT
Monitoring
A fix has been implemented for this issue. As of this time, system performance has returned to normal. We are continuing to monitor. Updates will be posted here as they become available.
Posted Apr 05, 2024 - 09:00 PDT
Investigating
We are currently investigating an issue where some SchoolMessenger Communicate sites are loading slowly. All hands are engaged on this incident. Updates will be posted here as they become available.
Posted Apr 05, 2024 - 08:40 PDT
This incident affected: SchoolMessenger (SchoolMessenger Communicate).